« Living Universe feat. 初音ミク&巡音ルカ / スペシャルコラボライブ | メイン | デバンドタフネスと護攻陣の相性の良さ ~ テクターさんでスーパーハード(SH)のヴォル・ドラゴンさんに再戦! »

2014年08月29日

マイクロソフト月例アップデート(8月の更新プログラム)更新のお話と、エピソード3のカスタムアンチエイリアシングプロファイルについて

まとめて記載しておきますね。


Microsoft、OSが起動不能になる問題があったセキュリティ更新プログラムを修正・再公開 “Windows Update”などを通じて自動配信

前回紹介したマイクロソフト月例アップデート(8月の更新プログラム)削除推奨のお話ですが、ようやくあのプログラム(KB2982791)を改修した「KB2993651」が公開されました。

すでにWindows Updateを通じ配信していますので、人によってはパソコン再起動時に更新が適用されたり、シャットダウン時にされるなど、画面をご覧になっている場合もあるかと存じます。ですので、適用されていうかどうかを確認する方法を再度記しておきますね。


「コントロールパネル」を開き>「システムとセキュリティ」の緑文字を選択>「Windows Update」の緑文字の下側にある「更新履歴の表示」をクリック。

KB2993651の確認方法するとこちらのような画面になるはずなので、後は該当の数字が含まれているかどうかをチェックするといいでしょう。もしも前回のプログラムをそのまま消されていなかった場合は、今回のアップデートで上書き更新されるようですので、その点もご安心を。

見当たらない場合は1ページ戻って、「更新履歴の表示」の右上に「更新プログラムの確認」があるはずですので、そちらをクリックし、リストを再度更新してみましょう。現れてくるはずです。

アップデートの概念は本当に難しいところなのですが、基本的には「Windows Updateは、よほど理由がなければ適用しておきましょう」というのが、私からの回答です。何か問題が起こるような事案があった場合は、本サイトをご覧の方でしたらそのあたりはすぐにキャッチできるようにはしますので、ご安心くださいなの・・・です?


そして、いよいよ一昨日からエピソード3が開始されました。みなさんは楽しんでいらっしゃいますか? 私は当日ほぼ遊べないままで(@_@) 昨日やってみたのですが・・・う~ん、いろいろと「絶妙かな」と感じる部分がありましたね。今一つ事例になるムービーを作成中ですので、しばしお待ちください。このあたりは明日語りたいと思います、はい。

その先行ログインで(午後2時に終わっていたのですよね・・・)軽くチェックしてはいますが、今のところ、現在提供しているカスタムアンチエイリアシングプロファイルにおいて、特に目立った問題はないように見受けられます。若干グラフィックスの質が変わったように感じますが(光源周りでしょうか)、いろいろと見渡していても いいアップデートなのでは と思っています。


影ことアンビエントオクルージョン、AOも目立った変化はなく。ロッティさんの髪型に線が入るのはご愛敬ということで_〆(; ;* ただ、一人の場合は影響が見られなくなったあたり? 多少は改善がされているのかなと思ったり思わなかったり。イベントフィールドをクロニクルでいくつかチェックしていたのですが、干渉がなくなっていたのですよね(末尾0Eのことです)。プロファイルに設定済みのものは、撮影時問題ありませんのでご安心ください。

いずれにしましてもまだ全フィールド回れてもいませんし、他に問題が起きないかどうかをチェックしてきたいと思います。なおプロファイルですが、先月からプラチナさんが提唱されているSLI compatibility bitsについて、GK110側のプロファイル値に反映してありますので、利用者さんは更新しておいてくださいね(最新版のみ反映)。いつもありがとうございます('-'*)

pso2_nvaa.zip(.nip) 最新版。ウイルススキャン済。解凍してご利用ください

pso2_nvaa_1405.zip(.nip) 2014年5月時点の前バージョン。ウイルススキャン済。解凍してご利用ください

EP3アップデート後の様子EP3アップデート後の様子EP3アップデート後の様子

本日は先ほどから? スクラッチも更新がされたようで、同時接続者数も27日に10万人再びを超え、2年超えて勢いがまだあるというのはすばらしいことではないでしょうか。PSUの時には見られなかったことであり、そういった部分では本当によくやっているなあって思いますね。

今のご時世においては、「成功する部分」をきちんと実践されている、ということの表れなのでしょうね。ガチャは現状の仕組みのままでは、さすがに褒められませんが・・・(@_@)


おまけ:愚痴となってしまっていたマイルームのお話ですが、公式サイトのこちらに記されているとおりで、

『マイルームテーマ「クラシック・テーマ」「クラシック・テーマ/P」「クラシック・テーマ/C」において、グラフィックが正しく表示されない場合があった不具合の修正』

とありますよね。つまり、そういうことなのです・・・(’’

(クライアントを信用できるわけなんてない、と。唯一信じられるのは 己が直感のみ 、です)


『PHANTASY STAR ONLINE 2』公式サイト
http://pso2.jp/

From : lavendy | 17:10

トラックバック

このエントリーのトラックバックURL:
http://lavendy.net/cgi/mt/mt-tb.cgi/479

コメント

はじめまして~、プロファイル関連で何時もお世話になっております。

プロファイルの更新や各記事を楽しく読ませて頂いております(´∀`)

今回のプロファイルに添付されている、GK110用に手を加えられた
物を試遊させて頂きましたが当環境からか、光源周りの反射を受ける物
や光を発してるような物"ちらつき"を感じておりまして(ロビーなどに
ある電子掲示板など)一報させて頂きました。

通常のcombinedモードでは発生しなく、新たに追加されてる物にのみ
確認致しました。

細かい仕様は省略させて頂きます、ドライバーは現最新の物を、GPUには
780を二枚、クライアントの描写設定から影3、ブラー、アンチをOFFに
クライアント側フレームを60(モニターに関しては120Hzのまま)です。

類似環境下で発生しないと言う情報があれば、小耳に挟んでおきたいなと
思います。長文失礼しました、更新や良きPSO2ライフを祈っております。

From : あっきー-Aki- | 2014年08月30日 15:08

あっきー-Aki-さんへ

はじめまして、こんばんわなのです('-')/
お褒めの言葉、ありがとうございます。プロファイルのご感想もいただけて恐縮です。励みになります。

あわわ・・・そうなのですか。GK110プロファイル側で、ですね。う~ん(@_@) 承知いたしました。比較すると把握できるとは思うのですが、変更点はAAとSLIのビット値だけなのですよね。それ以外は特に変わりなく。

とりあえず、そういたしましたら combined プロファイルを読み込んだ後、SLI compatibility bitsのみを 0x02C80015 という値に置き換えれば、エイリアシングが目立つことはなくなるかとは思います。一度お試しください。近いうちに再更新しておきますね。>再更新しました(31 AM1:01)

まだまだ各フィールドを全て駆け回れているわけでなく、検証が遅くなってしまってすみません。通常版で問題がないということは(もしかしたら開発さんたちもご覧になっているとすれば)、そちらを軸に調整されているのかな、という期待を持って(汗笑)。

私としては現状、これ以上最適な値を見いだせていないものなので・・・。丁寧なご報告、お言葉をありがとうございます。こちらもまた、何か進捗があればページに記載したいと思います('-'*)

EP3、いいですよね。楽しいのです。にはは。

From : らべ | 2014年08月30日 23:37

夜分にお手を煩わせてしまった上、とてもお早いお返事に感謝致します。

ご指定頂いた値にてテストさせて頂いた結果、完全な改善に至る訳では
なかったので、やはりSLIbit値での干渉と言う事になるんですかね?

中には落ち着いた場所もあり(武器屋さんの置くに掛かっている
コートエッジのような武器の刃周りなどが改善されていた)
悪化した方面で言えば、ショップエリア中央のお水周りが更にバチバチに
なっていた事くらいです。

特にこれが使えないから困る!と言う訳でもなく、症例の一つとしての
報告なので問題があれば各々問題のないプロファイルを使うでしょう(笑

実はSLI動作してなかった!とかならお笑い話になりますが、今は普通の
Combinedプロファイルを愛用させて頂きます!

これからの更新、ダークファルス【運営】との駆け引きなど
色々な楽しみ方がありますが、お互い楽しめる内に楽しみましょう!

From : あっきー-Aki- | 2014年08月31日 05:37

はじめまして、こんばんはです。
プロファイルの更新や各記事を楽しく読ませてもらってまっす。
AO使用時の動作について、すこしご相談したく書かせてもらいいました。
780Tiを3Way-SLIで動作時にAOを使用すると、SSを撮影時にクライアントが強制終了したり(エラー表示なし)、SSが保存されないといった現象が起こっており対処に困ってます・・・

ドライバーは最新で、2Way-SLIで同じプロファイルを使用した際は上記現象は起きないのです・・・
やはり、AOを切ってどうささせるしかないんですかね・・・?

From : エキレナ | 2014年08月31日 12:36

あっきー-Aki-さんへ

こんにちわなのです。お世話になります('-')/

あうう(@_@) そうでしたか・・・すみませんなのです。やはり、自分が持っていない環境については検証がかなわないため、トラブルシューティングも難しいものですね。本当に。

「値の意味するところ」がわかっていないことや、「値によってどのような効果をもたらしているのか」が把握できないと、適切なものは探せないと思いますので。ゆえに以前のようなグラフを見ながら、こうあるべきなのかな? くらいの追求しかできないのが難点です。AAはまだ、見た目ですぐにわかるものですから、探しやすい一面はありますけどね。

そうでしたか・・・となりますと、プラチナさんの環境では動くですとか、AOの掛かり具合までGK110カードは異なるようですから、上位カードならではの挙動も、追い求める必要がありそうですね。本当なら、セガさんやNVIDIAさんでやっていただきたいところではありますけど(@_@) その回答が汎用ビット値、ということなのでしょうね。

はい、もしもこの値で変わらなかったとすれば、SLI bitの立て方に問題があるとしかいえませんから(相違点はもはやそれだけですしね)、検証の難しさを思い知らされます。

あっきー-Aki-さんはそのあたりもお詳しそうですから、おっしゃるとおり、ご自身で使いやすいもの、組み合わせを見いだしていただけると幸いです。いやはや、本当にビット値の選定って難しいのです。

にはは。ダークファルス【運営】さんですか・・・ありそう、ありそうなのです!_〆(. .* 全体的にはよさげなアップデートだと思いますので、いろいろ遊んでみたいです(まだロクにプレイできておらず、なのでした)。


エキレナさんへ

はじめまして、こんにちわ。ご愛用いただき、ありがとうございます('-')/

ふむむ・・・これまたすごい使い手さんなのです!(@_@) 本当、PSO2プレイヤーさんっていろんな方がいらっしゃるのですね、と思わされるのでした。にはは。

780Tiを3Wayともなりますと、プラットフォームも気になるところです。いわゆる、エンスージアスト向けといわれる「X58/X79」などを使えているか、が一つ気になりますね。


たとえば、最近の主流となっているSandy/Ivy Bridgeのブロックダイアグラム(ブロック図)はご覧のようなものになるのですが、グラフィックスカードとCPUとを結ぶPCI-Expressのレーン数が16(・・・要は1枚のみでの利用)となっているため、

3Wayともなればx8-x4-x4といった構成でデータ転送を行う必要が出るのですよね。そこで、2Wayまでなら問題ない、とのことですのでおそらく値の問題というよりも、ハードウェア的な部分で何か問題が潜んでいないかな、と感じるところです。すでにこのあたりをご存じ/お持ちでしたら、大変失礼いたしました。

対するX58シリーズX79シリーズ、つい先日出たばかりのX99シリーズはご覧のように36~40レーンと広帯域になっており、各カードの実力を余すことなく発揮できるようになっています。お話のような、AOを入れて撮影ともなるとかなりの負荷がシステム上にもかかっているはずですので、目に見えない部分の安定動作は、このようなところからももたらされている・・・といったところです。


もしもXプラットフォームではなくZやPといった一般向けのマザーボードとなれば、カードを接続するところによってはx8までですとか、x4までですとか、レーン数に制限があるところもありますので、そのあたりはマニュアルをお読みになって、カードの接続先を変えてみる、なども一つの方法になります。しかしながら3Wayですので、ほぼ選択の余地がなさそうな気がします・・・(@_@)

となれば、あとは電源ユニットでしょうか。780Tiの3Wayですから、カードだけでも瞬間最大出力=700W以上が見込まれますので、CPU含めたプラットフォーム全体の消費を鑑みますと、1000Wクラス以上の電源が望ましい、ということになりそうです。おそらくこれほどの環境ですからCombined+AOなりされていそうな予感がしますけど、そうともなるとシステム全体にかなりの負荷がかかりますので、そのあたりも見直してみたいところですね。

2Wayなら問題がない=負荷が下がった、ともいえると思いますので。念のため、使用しているCPUの名前と電源容量、あとはプロファイルを教えていただけると幸いです。TITAN 3Wayで動かされている方もいらっしゃるわけですので・・・。

From : らべ | 2014年09月01日 15:43

早速の回答ありがとうございます。
環境なのですが、以下のとおりです。
CPU:Core i7 4930K
メモリ:48GB(8GB*4+4GB*4)
SSD:840PRO 120GB
マザー:RAMPAGE IV EXTREME(X79チップ)
電源:EPM850EWT+SST-ST75F-P(計1600W)
GPU:N780GTX-Ti Twin Frozr 4S OC*3

見てもらうと、分かると思いますがすごく変則的な構成になっています。
電源はSST-ST75F-Pをグラフィックボードの補助電源に、それで足りない部分をEPM850EWTからといった感じです。

プロファイルは通常のCombinedを使っています。
GK110のプロファイルは、使うと3AFR動作時に光源が点滅を繰り返すので使っていません。

負荷についても確認してみましたが、2Way時はロビー等でGPU使用率75~80%、3Wayだと30~60%といった形になりました。

長文になってしまい、申し訳ないのです・・・

From : エキレナ | 2014年09月01日 18:50

プロファイル更新お疲れ様です。
やはりロビーが明るいのはいいですね!
新プロファイル使用してみますねー

From : WK | 2014年09月02日 10:56

エキレナさんへ

お世話になります。あわわ・・・。まさしく頂点を極められている構成で、前回のコメントは全く見当違いになりますね。大変失礼いたしました。長文は、私が長文使いなのでお気になさらず(@_@)

Rampage IV Extremeともなれば超マニア向けのマザーボードだと思いますので、かなり難しそうですね。もっていないため、とりあえず説明書を読みましたところ・・・このあたりがチェックポイントになりそうです。すでに試されていたらすみません。


ハードウェア(マザーボード本体)
2-37:EZ_PLUG_1/EZ_PLUG_2

こちらの画像、左奥の2つのコネクタ(EZ_PLUG_1(PCI-E 6pin)/2(FD 4pin))が補助電源コネクタとなりますが、こちらのEZ_PLUG_1にPCI-E向けの電源が刺さっているか、が一点。

ESATA6G_USB3_34(オーディオコネクタのすぐ左隣にある、eSATAとUSBコネクタ2つ(青色))は、USB3.0の青コネクタを使用不可ととらえてください(IRQ割り込みがPCI-Expressと同じことから、トラブルを避けるため)。


ソフトウェア(UEFI BIOS部分)
3-16:PCIE Spread Spectrumを[Disabled]に
>EMI対策を無効にすることで、限界時の挙動を安定させる


3枚での負荷率低減まで試されていらっしゃるご様子ですから、Inspector側の設定ミスはおそらくない(ないし、極めて少ない)ものと判断できます。

スロットは普通に、上から1スロット間隔で3枚差し込まれているものと思われますので、そちらで特に問題はないでしょうね。気になる部分があるとすれば電源二重化のところでしょうけど、特定条件下でなければトラブルは発生しないようですから、ハード起因は薄いように感じるところです。


GK110プロファイルはだめだったのですね(@_@) う~ん・・・。自分でそのクラスのカードを所有しないと、なんともわからないのでした。

ヅネさんもおっしゃるとおり、ドライバーレベルはもちろんのこと、ハードウェアでもメモリ周りが異なりますから、動作条件はかなり変わるのかもしれないですね。GTX 690はグレード的には上位カードでも、本質はGTX 680*2ですから、みなさんが利用されているカード向けなのかな、と。

いずれにしましても、AOを入れると安定しない、2Wayに落とすと問題がなくなるということから、決して利用できないわけではなさそうですけど、上記を確認後変わらないようであれば、試しにAOのビット値の末尾を、「0E」に変えてみて、変化が出ないかどうかあたりも、一度確かめていただけますでしょうか。

撮影されない現象もあるということで、PSO2クライアント側の不備ももちろんあるところと考えられますが、PSO2で使えるAOは実質3つ程度しかありませんので・・・。選択が、難しいところです。

お手数をおかけいたしますが、よろしくお願いします。


WKさんへ

はじめまして、こんばんわなのです。

いえいえ、こちらこそご利用いただき、ありがとうございます。
今のところ特に前と変わる設定にはなっていませんけど、近いうちに「私が使用しているもの」は同梱しようと思いますので、ご興味がある方はトライしていただければと('-'*)

今日のお題に、そのあたりは補足していますので、ご参考にどうぞ。


いいですよね、EP3。光源が少し柔らかくなった部分もあるような感じで、まだまだどっぷりと浸れているわけではないのですが、いろいろよくなっているようで、ゆっくり遊んでみたいですね。にはは。

From : らべ | 2014年09月03日 20:02

回答ありがとうです。
らべさんが書かれたことを全部試してみたのですが、やはり現象が再現してしまうのです・・・

AOのビット値に関してなのですが、どの値をいれても現象が発生しにくい等の違いは見受けられませんでした。

あと、統計的に現象が発生しやすいのがロビーからショップエリアへの移動後やAlt+tabでの画面切り替え後の戻しの撮影なので、AOの処理で何かしら干渉が発生してるような気もします・・・

他に何か調べられることって、あったりしますか・・・?

From : エキレナ | 2014年09月04日 03:40

エキレナさんへ

ご回答、ありがとうございます。思うところ全て見直されているようで、考えているところは同じようですね。

どの値を入れても・・・となりますと、おっしゃるようにディスプレイドライバー周りか、あるいは他の外部ユーティリティーなどとの競合かが考えられそうですが、何か利用はされていらっしゃいますか?


変わりまして、840ProはおそらくサムスンさんのSSDと思われますが、特にキャッシングツールなどは添付されていないモデルとなりますよね。もしもRAMDISKなどがございましたら、いったん解除してどうなるか、は考慮した方が良さそうでしょうか。

私もAlt+Tabで切換はしていますが、特に安定性が落ちるようなことはなく。ただ、しばしばメモリエラー(Readになること)は起きていますね。3Wayで運用されているようですので、解像度はWQHD(2560*1440px)あたりでしょうか。

場合によってはそのディスプレイ側とのやりとりで問題が起きている可能性も全くないとは言い切れませんし。高解像度環境下はそのあたりも気をつけたいところにはなります(人によってはディスプレイケーブルを別のものに変えて安定した、なんて話もあったりします)。中継器やセレクターなどもしかりで。単体・直結構成ですね。ほとんどの方はそうだと思いますが。


そうですね、AOは本当に内部でどのような処理を行っているかまではわかりませんから、明確な回答が難しいのですが。値による差異がないということは、Inspector側の問題とは考えにくいことにもなりそうですしね。

今いえることとしてはご利用の解像度と、ディスプレイの構成などでしょうか。切り分けとしてはどの解像度にしても同じ症状が現れるのかどうか。マルチディスプレイ構築済みなら、一度単体に戻してどうなるのか。

後、見落としがちなのがオプションメニューにある「詳細モデル表示数」。どうにも、こちらが50を超えた値(51以上)になっていると、AO以前の問題で読み込みエラーを頻発するようです。こちらはPSO2プログラム側の問題だと思っていますけどね。

From : らべ | 2014年09月04日 09:39

回答ありがとうございます。
自環境は、ProLite XB2776QS単体で解像度をWQHD(2560*1440px)でやってます。

で、先程らべさんの話を聞いてもしかしたらとお思い、クライアント側のカスタム解像度を1920*1080の標準の値に戻して、試してみたところ現象がでなくなりました!

ただ、DisplyaPort、HDMI、DVI-D全ての接続でカスタム解像度でプレイすると現象が起こってしまうことも分かりました・・・

んー、こうなるとディスプレイが原因なんですかね・・・

From : エキレナ | 2014年09月04日 11:41

わあ・・・そうでしたか。解像度をひとまず下げると症状が現れなくなった、と。これで一つ線引きはできましたね。

すなわち「Inspectorの設定値」なり「Rampage IV Extremeの配線や設定」には問題はないでしょう、ということを。

いえいえ、モニター側の問題の可能性は少ないと思われます。ごく一部、ごく稀なケースでそのような現象もあり得るとしただけで、ほとんどはないものですね。穿った見方、というわけです。全入力系統までお試しいただいていますから、そのあたりも安心材料にはなりそうです。


だとすれば、気になるのはあと2つほどで、たとえば「撮影時『だけ』高確率で落ちる」ようであれば、そのデータを書き込む先となるストレージデバイス(SSDなりHDDなり)とのやりとりがうまくいっていないということになるでしょうし、

実際に「撮影、はどのようなものを使われているか」。私の環境下ではご指定のCombined+WQHDの条件でも問題なく撮影はできるのですよね。いわゆる静止画部分となる本体のPrintScreenであったり、そして録画をする部分となるDxtoryであったり。ビデオメモリが2GBなために、慢性的な不足には見舞われていますけど。

使われているソフトにもよりますが、キャプチャーソフトによってはOSDがらみでPSO2と衝突するものも中にはあるものと考えられます。代表どころでは、フリーで使えるRivaTunerあたりでしょうか。ファンコントロール/OCセッティングツールとしても有名なMSI Afterburnerなどが候補ですね。

Dxtoryにおいては少なくともそのあたりをクリアし、親和性はそれなりにあるものとしています。その際はこちらのような設定を施し、動作するかどうかを見極める、といった感じでしょうか。


クライアントの撮影機能は負荷が高いときに正常処理されない兆候は確認しており、この場合はストレージデバイスの能力以前に、「PSO2クライアントそのものが、正しくデータをはき出せていないような作りになってしまっている」、と私は結論づけています。それが「ランチャー外の解像度=カスタム解像度を用いたときの弊害」、といえそうです。

WQHDのCombinedは内部データで5120*2880px相当の情報量を持つことになり、UHDをも大幅に超えるもの(約2倍/1540万ピクセルのレンダリング)となっています。本来780Ti*3にものぼる構成であればそのあたりをハンドリングする能力はあるものと考えられますが、GeForceドライバーの完成度によるものなのか、PSO2の完成度に依存するものなのか、の線引きまでは明確にはできていません。

ゆえ、あとエキレナさんにお試しいただけるものがあるとすれば、このDxtoryなるソフトを導入し(動作確認のみですから購入をする必要はございません)、正常に撮影できるかどうか。

もしも成功するようであればまさしく「PSO2クライアントの問題」と結論づけられるでしょうし、そうでなければ「環境固有の可能性」となってしまう恐れもあることでしょう。まずはこちらを用いて、別の撮影ソフトにおいても症状が再現されるかどうかを見極めるのがあると思いますね。


後は念のため、ストレージデバイス向けのドライバー・・・Intel Rapid Storage Technologyの最新版を適用し、安定するかどうかもあわせてお試しください。

(最新版は5/27/2014、13.1.0.1058(Latest)となります。X79向けにはサーバーグレードのenterprise版(IRSTe)ドライバーもありますが、今のところ上記一般向けのドライバーで、安定して動くことを確認しています)

From : らべ | 2014年09月04日 18:02

早速の回答ありがとうございます!

らべさんからの回答でストレージで気になる点があったので、環境を以下のように変更しました。
・SSDの寿命延長のために、OSインストール時にHDDへ移動していたマイドキュメント関連のフォルダを全てSSDに集約

【変更後】
クライアントでの通常撮影だと現象変化無し。
ただ、詳細表示数50でもメモリーエラーが多発するようになり、表示数を下げていき40位だと出ないことを確認しました。

Dxtoryを使用しての撮影に関しては、変更前だと撮影が出来なくなる現象が発生していたが、変更後は撮影に一切問題なし。
ただ、Alt+Tabで画面を切り替えてもどるとAOが外れる現象が発生。

結果として、なんとも不思議?な感じになってしまっていますね・・・

HDMIのケーブルを新しく入手する予定が出来たので、それを使って変化がないか再度試してみます。
結果はまた、コメントしますね。

From : エキレナ | 2014年09月05日 00:14

おはようございますなのです。・・・って、あわわ(@_@)

あ、あくまでケーブルのお話は特殊なケースであり、今回はエキレナさんですでに3系統の入力全てで確認されていらっしゃるワケですから、「問題は考えにくい」としているわけなのです。

人によってはデュアルリンクDVIケーブルそのものでなかったりですとか(WQHD自体が不可能ですしね)、そのケーブルが断線しかかってて映像がついたり消えたりするですとか。そういった症状の時に疑う項目なのですよね。

一昔前・・・3~4年以上前でしたらそのあたりがまだ出始めだったということで、製品がこなれていない部分もありましたので、確認しておきたいところになりますけど・・・おそらく問題ないかと。


その他の条件を記してくださっていて、ここが手がかりになりそうですね。そう、表示数を減らしたら間に合うようになったみたいですから、要するにVRAM=ビデオメモリ不足が考えられるようになってきそうな予感です。

解像度をWQHDからFHDに下げると、内部演算のレンダリングピクセル数はCombinedプロファイルの場合、約1500万から約830万と、ほぼ半減します。4割強のカット、ですね。ヅネさんがお持ちのTITANで何とか間に合っているといった感じですから、その半分となる3GBのビデオメモリでは、WQHDをハンドリングするのは難しいのかな、と。プロセッシングパワーは十分あるはずなのですけどね。その受け皿が足りない、というわけなのです。

となれば、カスタム解像度の値を 2240*1260px あたりにしてみるですとか、若干下げ気味にしてみるのがいいのかもしれませんね。Inspectorのモニタリングツールなどでも確認してみるといいでしょう。

目標ラインは75~80%程度の使用率です。それ以上は表示化けや不安定化などの原因にもなりかねませんので、上限で2.5GBあたりを目安にしてください。


AOが解除される現象は、よく取り沙汰されますよね。私の環境下では起こらないのですけど・・・。何かフルスクリーンと干渉するようなソフトがないかどうか、も気がかりなところです。ただ、そのあたりがVRAM容量に左右される可能性はありそうで、

本来WQHDの解像度であれば、理想となるビデオメモリのサイズは4GB程度となるはずです。そこに微妙に足りていない780TiはやはりCombinedではなくその他のものを・・・が推奨ラインとなるのでしょうね。

私はそれ故、GTX 690ではミドルクラスと何も変わらないですから、CombinedはあきらめてMSAAとなるadvanced_lightにとどめているのでした。再来週にいよいよお披露目となるGTX 980でようやく4GB/8GBのメモリを搭載するとされていますので、

このあたりの次世代カードが出てくれば、WQHDやUHDなどでも、SSAA系のアンチエイリアシングもかけられないこともなくなる、のかもしれませんね。とはいえ、UHDにもなればMSAAやFXAAで間に合いそうな気はします。


ストレージ周りは盲点になりがちですが、映像データをVRAMからPCHを経由させ転送するわけですので、可能な限りトラブルは避けておきたいところなのでした。

WQHDともなれば一瞬で結構なピクセルを書き出すこととなります。UHDにもなってくると、それはより顕著なものとなってきます。解像度は高いのに書き込み先が遅いようでは、話になりませんしね。

ゆえ私はトラブルを未然に防ぐため、静止画/動画ともにSSDにすべて書き込むように設定しているのでした。お金はかかりますが、安定性や速度が段違いですからね。にはは。

(PSO2クライアントからの書き込みだけはHDDです>ただし、書き込みに強いWD30PURXとしていますね)

From : らべ | 2014年09月05日 08:56

早速、カスタム解像度を2240*1260で試してみました!
すると、SSを撮影してもAOが切れたり撮影できなくなる現象はなくなりました!

うーん、折角ならWQHDの解像度でやれるのが一番なのですけど・・・
あ、あとやはりこのFHDの解像度の場合、影品質は3以上だと表示がおかしくなるってことでいいんですよね?

From : エキレナ | 2014年09月06日 00:40

やっぱりなのです。プラチナさん曰く、「私と同じ道を辿っている」・・・と。これ、最初ヅネさんもお話しされていたことなので、高解像度環境下の方にとっては悩ましい問題なのでしょうね。

曰く、「横幅が2560の時点で、縦1061px以上にすると影品質5ですでにメモリは3GBを突破するよ」、と。彼はTITAN SLIにしていましたので、現在問題は起こっていないようですが。


うんと、公開当初から常々記していますが、メモリイーターの諸悪の根源は「影品質4/5で実現される、『付け足しで貼り付けられる平面の影』」であることはすでにわかっており、それがために「影品質3以下でご利用ください」としているわけです。

影3の状態で試されたことはありませんでしょうか? 実現可否以前に、使用メモリ量が格段に下がることを確認できるはずです。メモリ帯域を要求されるのは、そういった「手抜きと思われる表現技法が徒となっている」としか、私にはとらえられないのでした。

ですので、あれだけの長いInspectorの覚書や考察を記したのも、「(プロファイルをいじられる=環境面などであわないところがあり?)そういった現象に対してありとあらゆる試行錯誤をし、ご自身で気づいてほしい」がためです。

でなければ、「プロファイル通り」かつ「添付文書通り」お使いください、というのが私からの回答ですので。「知らぬが仏」というのは、こういうことなのですよね。これだけでもいらぬ時間を浪費しているわけですから。

私としてもそのため「膨大な時間を要して作成している」、と書いている訳なのです(いってしまえば4~500時間は消費しています)。


現に、今のトラブルシューティングだけで、もしもリアルに解決手数料を取るものだとすれば、料金換算でいきますと・・・これだけで1万円超はとられる内容ですので(汗笑)。

げに恐ろしきサポートの世界~!(byパティちゃん)
なのでした□_ヾ( ̄∀ ̄*)


そんな向学心のあるエキレナさんには、ヅネさんが主宰されるチームAIGRをおすすめしておきます。最近プラチナさんも加入され、ますます濃いメンバーさんが集結されているのだそうです('-'*)

AIGR Inc.


(私は・・・一人のんびりが性に合うものなので。
 異端者ですしね。にはは)

From : らべ | 2014年09月06日 12:40

わわ、本当にげに恐ろしきサポートの世界ですね!?

ふむふむ、チームですか・・・
うん、Ship7にお邪魔することがあれば、入ってみようかと思います。

あ、えっと先日コメントした後に、影品質を3でしようとしたのですが、別の現象が発生していたことに気づきました。何故か4以上で発生している表示がおかしくなる現象が影品質2で起こるという感じになってます・・・

影品質1の状態で、検証していたので気づかなかったのです・・・
この状態って、らべさんは起こったこととかありますか?

From : エキレナ | 2014年09月06日 13:58

チームの件は余談ですので(@_@) 真に受けすぎず十分なのです。楽しいところではあるみたいですけどね。にはは。デイリーオーダーなど専門にこなすところなどもあるそうですよ。

あら・・・それは初耳ですね。基本的にはまとめに書いてあることでもありますが、1がlow、2/3がmiddle、4/5がhighとなるわけですけど、大半問題が起こるのはhighとなっており、low/middleで問題が発生する症状は、こちらでは確認できていません。

念のためこちらでも今確認しましたが、私の環境下では克服できているのか、2560*1440pxでは何の問題もなく影の1~5の各種切換、AOがはずれる現象も見当たりませんでした。


そもそもCombinedはいろいろ調べているうちに「PSO2と根本的に相性が悪いモードですね・・・」とがっかり感が拭えず(PSUはこれだけで神の見栄えになりましたので)、ブルートフォース(力押し)で解決策は導かれたものの、それだけゴリ押しを要求されるわけで、スマートな解ではないなと思いまして。

このままでは「ハイエンド環境でないと再現不可能」なことと、「MSAAである程度は満足させられても、『真の姿』は見せられないでしょうね」と。同じやるならそこまでやりたかった人ですから、さらに時間を費やして・・・

そうして錯誤の末導き出されたのが、Extremeプロファイルだったりします。撮影目的であれば、フルフレームレート=完全60fpsにこだわらなければ、十分達成されますから。

私としてはCombined系を「PSO2のイレギュラーに抵触する、条件=曰く付きプロファイル」としてしかサポートができないのですよね。ゆえにCombined系はあれやこれやと注記するワケなのです。真の上級者向けということです。


遊んでいて気づくこととしては、どうにもSSAAと2D表示部が干渉するようなのですよね。それも「PSO2が規定する解像度内では」。

一応、プロファイル群は未明に更新しておきましたので、改めてそちらのファイルを使ってみるのもありかなと思います(私のサンプルも入っています)。プラチナさんやヅネさんは0x42C系を使われていらっしゃる?ようですので、そちらに近似した値で定義しておきました(GK110)。

私のサンプルの0x02C14405というものはいわば「Race Driver Grid」の規定値と、0x02C系の組み合わせで実現しているものです。使用するAOにあわせてSLI compatibility bitsも変えているということですね。そこまで全て考慮したプロファイルが、7月末からお配りしている「私なりの、最終(と思っていただいてもいい)プロファイル」となります。

明確な根拠はありませんが、その値だとあらゆる場所での安定性が、私の環境下では認められましたので。ゆえにあのお題を作成し、ご納得いただけますでしょうか、と提案したわけなのです。


GK110はメモリバンド幅が384bitと広帯域になっており、何かしら私ら一般ユーザーが使うGK104とは細かい部分が異なるのでしょうね。ヅネさんが最初冗談チックに話されていたお題が、実は結構な違いをもたらしているのでは・・・と、つくづく思うのでした。

(なんだかGK110ではMirror's Edgeの02が使えるみたいですしね(@_@))

一度、オプションで設定の初期化を試してみるのもありなのかな、と思います。私の環境下では1~5がスムーズに切り替わるがため、これ以上の詳細はわかりかねます。べたですが、膨大になったクライアントの入れ直し・・・が効果あるのかは不明ですが。サポートの一環としては提案しますね。

It-tellsさんなどで、このあたりを話せる方がいらっしゃれば、一番いいのですけどね。後はどなたかこのコメントをご覧になっていらっしゃるか。同じ環境の方はおられるものなのでしょうか・・・。


ご参考までに、影品質1のlowはマイキャラのみ(その影解像度も最低状態(16*16px)程度?)、2のmiddleは影解像度が倍の32*32px程度?もマイキャラのみ、

3は2のマイキャラに加えて、パーティーまで描画されるようになり、4/5でエネミーさんやオブジェクト周りにも影が入る・・・といった具合です。

アルファテスト時では各項目ごとにチェックがOn/Off可能な仕様になっていたのですけどね・・・。


私の環境ではこれ以上の再現が不可能なため、お話できるのはこのあたりまでとなりそうです。直接的な解決に結びつかず、申し訳ございません。

From : らべ | 2014年09月06日 15:20

早速の回答ありがとうございます。
初期化をしたら、影品質3で問題なく表示できるようになりました!ただ、PSO2内での影品質を変更すると、表示がくずれますね・・・(1、5どちら側でも)
なんか変な設定値が残っていたんでしょうか・・・
うーん、自環境ではMirror's Edgeは動かないみたいです。

色々とありがとうございました!

From : エキレナ | 2014年09月06日 16:17

どういたしましてなのです。にはは。

う~ん・・・そうですか。ランチャー外の解像度(=カスタム)であれば、通常その影響を受けないはずなのですけどね。となると環境固有の問題の可能性も出てまいりますので、後の提案はお時間があるときにでも、OSの入れ直しから試してみるといいのかも・・・となりそうです。

はい。ソフトウェアの初期化や入れ直しって軽視されがちですが、侮れないのですよね、これ。最近のソフトウェアは相互にいろいろなファイルを作り出しますので・・・。特にPSO2は常々申し上げている「クライアントそのものが限りなくアヤしい」存在のため(汗笑)、看過できません。


以上、もしも一連のやりとりをご覧になった方にいえることは、こういうことが「サポートをする」、というわけなのですよ。

今のようなプロセスを、ひとりひとり、こなさなくてはならないわけですが・・・対応できますか?

・・・その手間暇がバカにならないため、そしてこれだけ時間がかかっても完全解決に至らない場合もありますので、

「プロファイル通りご利用いただくのはいかがですか?」

と、何度も記すのでありましたとさ_〆(. .*


私においては、ムービーがすべてを物語っていますので。

From : らべ | 2014年09月06日 17:32

連投失礼します。
先程の件に関して、user.pso2内の設定で挙動が変わるようなので書いておきます。
Draw = {
ShaderQuality = true,
Shadow = {
Quality = "middle",
},
Display = {
ShadowQuality = 2,
ReflectionQuality = 5,
DitailModelNum = 30,
},
ShadowQuality = 3、Quality = "middle"となるとオブジェクト周りに影が入るようになっています(植物等のオブジェクトの影が貫通する現象発生)。
Quality = "low"、"high"に関してはShadowQuality = 1から変更すると、表示がおかしくなるようです。

From : エキレナ | 2014年09月06日 17:33

おっしゃる通りです。その内容が設定値まとめの後編に記してある、一覧表となるわけです。

今回のトラブルは結局、いいたくありませんが「PSO2本体の問題だった」わけなのですから。断定こそはできませんが、ほぼ黒でしょう。

なので「ね、でしょう?」といいたくもなってしまうものなのですよ。とほほ。

ご覧になっている方もいらっしゃるのでしょうし、では、ここにuser.pso2の値の変動値を改めて書き出しておきましょうか。


設定1

Draw = {
ShaderQuality = false,
Shadow = {
Quality = "low",
},
Display = {
ShadowQuality = 1,
ReflectionQuality = 1,
DitailModelNum = 5,
},
Function = {
Blur = false,
LightGeoGraphy = false,
Reflection = false,
LightShaft = false,
SoftParticle = true,
Bloom = false,
Depth = false,
LightEffect = false,
AntiAliasing = false,
},
TextureResolution = 0,
},


設定2

Draw = {
ShaderQuality = true,
Shadow = {
Quality = "low",
},
Display = {
ShadowQuality = 2,
ReflectionQuality = 2,
DitailModelNum = 5,
},
Function = {
Blur = false,
LightGeoGraphy = false,
Reflection = true,
LightShaft = false,
SoftParticle = true,
Bloom = false,
Depth = false,
LightEffect = false,
AntiAliasing = false,
},
TextureResolution = 1,
},


設定3

Draw = {
ShaderQuality = true,
Shadow = {
Quality = "middle",
},
Display = {
ShadowQuality = 3,
ReflectionQuality = 3,
DitailModelNum = 12,
},
Function = {
Blur = true,
LightGeoGraphy = false,
Reflection = true,
LightShaft = false,
SoftParticle = true,
Bloom = false,
Depth = false,
LightEffect = true,
AntiAliasing = true,
},
TextureResolution = 1,
},


設定4

Draw = {
ShaderQuality = true,
Shadow = {
Quality = "middle",
},
Display = {
ShadowQuality = 4,
ReflectionQuality = 4,
DitailModelNum = 20,
},
Function = {
Blur = true,
LightGeoGraphy = false,
Reflection = true,
LightShaft = true,
SoftParticle = true,
Bloom = true,
Depth = true,
LightEffect = true,
AntiAliasing = true,
},
TextureResolution = 1,
},


設定5

Draw = {
ShaderQuality = true,
Shadow = {
Quality = "high",
},
Display = {
ShadowQuality = 5,
ReflectionQuality = 5,
DitailModelNum = 30,
},
Function = {
Blur = true,
LightGeoGraphy = true,
Reflection = true,
LightShaft = true,
SoftParticle = true,
Bloom = true,
Depth = true,
LightEffect = true,
AntiAliasing = true,
},
TextureResolution = 2,
},


以上となります。こうしてみていくと、あれ・・・? 変ですね、となったのがソフトパーティクル。なぜか全てで true となっていたりするわけなのですよね(@_@)

なので、こちらも初期化をしてみましたけど、その後ようやく直るといった具合で。こんなところからしてランチャーの書き出しも正しくできていない現象が確認できるわけです(おそらく自身で別途ソフトパーティクルを有効にした場合、それがランチャーから設定反映できていない?)。

私固有の環境かどうかはわかりかねますが、こんな小さな問題でもいろいろと起こっていますから、正直「何をもって正常な動作と見なせるのか」、その基準が「わかりません」、というわけなのです。クラシックテーマのバグもそんな感じですからね(@_@)


となるとエキレナさんの環境下ではその設定で問題が起こるということで。私の環境下では起こらない、ものですから、さてはて、何が問題になっているのでしょうね。にはは。


(おそらくチート対策などでプロファイルの値を毎回ランダムな並びにしているのだと思いますが、このような部分からほころびが出ているような気がしてならないのでした。

・・・詳細、の英単語すら間違えるようでは(@_@)
(DitailではなくてDetailでしょうに・・・))

From : らべ | 2014年09月06日 18:50

話題に乗り遅れt

高解像度でのSS撮影がうまくいかないorクライアントが落ちる現象は当方でも起きております。
これはPSO2クライアント制御でSSを撮影した際に画面右下に付与されるロゴマークの処理のせいかな?と、別のタイトルで起きていた事例から推測。
解像度が高いと内部処理が間に合わない?かロゴを挿入するピクセル位置が想定外?なためにおかしな画像を吐き出したり、撮影そのものが失敗したりetcetcとなっていると思います。
(影4/5問題で話題になっていたあたりの解像度を境に失敗してるようなので、もしやこれは・・)
外部ツールであれば解像度3840x2160にしていても失敗しませんので当面はこれで凌ぐつもりです、、

ハードにまつわる問題というのは少なくなってきたかと思います。
(主にnVidia側のドライバ改善努力デスヨ)
当方ではDP-MST接続の4k解像度ではありますが、らべさんのExtremeやCombined準拠相当の設定でもVRAM3GB以内で賄えていますし、十分にゲームをストレスなく楽しめるレベルにまで改善されてきてると思います。
(一年半くらい前はモニタ映る/映らないというレベルの会話でした・・)
好みの設定で問題なくプレイできる日が来るといいですなあ・・

(あとはもうbit探し終わらせたい。)

From : ヅネ | 2014年09月08日 02:41

ヅネさんへ

こんばんわなのです。あはは・・・そうですね。
乗り遅れるも何もありませんのでご安心を_〆(. .*

私の環境下ではクライアント落ちまでは確認できていないものの、おそらく高解像度になるとその著作権表記挿入のプロセス時に何かしら問題が起きやすいのかもしれませんね。といいますよりも、ランチャー外の解像度は彼らとしても想定外のはずですから・・・。

(内心「いじるな、いじるな!」と思われていらっしゃることでしょう(汗笑))

おっしゃる通り、外部撮影ツールを使ってキャプチャーするのが、現状での解となりそうですが。SSDあればとりあえず何とかなっていますし(4K解像度での録画はさすがにきついですね・・・)。

というよりも、PrintScreen連打をしても、全然その連打に追従できない撮影速度では、とてもではありませんけど戦いの最中の撮影なんて間に合うわけもないのですよね(汗笑)。なので論外、と(@_@)

それこそヅネさんのフットスイッチが大活躍するのではないでしょうか。にはは。羨ましいのです。


う~ん、ドライバー側の問題なのかは正直わかりかねるのですよね。ただ、4KをはじめとしたUltra HDなる解像度は最近ようやく表舞台に立ったばかりというのは看過できないことでしょう。おっしゃる練り込み不足は当然、ドライバー側にもあるはずですから。

ヅネさんはまさしく出始めから問題に向き合ってこられているはずですので、そのあたりのノウハウは十分お持ちでしょうしね。私は・・・ほんと、何の問題もなく映し出されているので、恐縮しきりではあるのですが。ただ、HDMI2.0がないため、60fpsでの動作はまだ確認できていません(4:2:0ではできましたが、安定はしないような)。

ほええ・・・いいですねえ。3GB以内で動くのですか。これも環境依存な部分などがあるのか、不明ですけど・・・。いずれにしましても値探しを含め、来週発表とされる900番台から、何かが変わってくれるといいのですけどね。Maxwellは効率がだいぶ上がりそうということで、ちょっぴり期待しているのでした。

From : らべ | 2014年09月11日 00:34

コメントはご自由に



(書式を変更するような一部のHTMLタグを使うことができます)